using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*?)(fieldid=)*(')*(\d*)(')*";
string substitution = @"$4";
string input = @"blah blah fieldid='123456'
blah blah
blah blah fieldid='123457'
blah
blah blah fieldid='123458'";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}