# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/;[\p{Zs}\t]+(?=[^\W\d]+\d\w*\r?\n)/;/gm;t' <<< "N10 ; G30
N10 ; G30"