const regex = new RegExp(';[\\p{Zs}\\t]+(?=[^\\W\\d]+\\d\\w*\\r?\\n)', 'gm')
const str = `N10 ; G30
N10 ; G30`;
const subst = `;`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);