re = /;[\p{Zs}\t]+(?=[^\W\d]+\d\w*\r?\n)/m
str = 'N10 ; G30
N10 ; G30'
subst = ';'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result