using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @";[\p{Zs}\t]+(?=[^\W\d]+\d\w*\r?\n)";
string substitution = @";";
string input = @"N10 ; G30
N10 ; G30";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}