#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m);[\p{Zs}\t]+(?=[^\W\d]+\d\w*\r?\n)"
Local $sString = "N10 ; G30" & @CRLF & _
"" & @CRLF & _
"N10 ; G30"
Local $sSubst = ";"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)