use strict;
my $str = 'N10 ; G30
N10 ; G30';
my $regex = qr/;[\p{Zs}\t]+(?=[^\W\d]+\d\w*\r?\n)/mp;
my $subst = ';';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";