import re
regex = re.compile(r";[\p{Zs}\t]+(?=[^\W\d]+\d\w*\r?\n)", flags=re.MULTILINE)
test_str = ("N10 ; G30\n\n"
"N10 ; G30")
subst = ";"
result = regex.sub(subst, test_str)
if result:
print(result)