$re = '/;[\p{Zs}\t]+(?=[^\W\d]+\d\w*\r?\n)/m';
$str = 'N10 ; G30
N10 ; G30';
$subst = ";";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;