import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ";[\\p{Zs}\\t]+(?=[^\\W\\d]+\\d\\w*\\r?\\n)";
final String string = "N10 ; G30\n\n"
+ "N10 ; G30";
final String subst = ";";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}