# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^{\R\h{2,}label:\h+"[^"\\]*(?:\\.[^"\\]*)*",\R\h{2,}value:\h+"[^"\\]*(?:\\.[^"\\]*)*",\R},//gm;t' <<< "{
label: \"Other\",
value: \"Other\",
},
{
label: \"this is \\" a test\",
value: \"1234\",
},"