re = /^{\R\h{2,}label:\h+"[^"\\]*(?:\\.[^"\\]*)*",\R\h{2,}value:\h+"[^"\\]*(?:\\.[^"\\]*)*",\R},/m
str = '{
label: "Other",
value: "Other",
},
{
label: "this is \\" a test",
value: "1234",
},'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result