use strict;
my $str = '{
label: "Other",
value: "Other",
},
{
label: "this is \\" a test",
value: "1234",
},';
my $regex = qr/^{\R\h{2,}label:\h+"[^"\\]*(?:\\.[^"\\]*)*",\R\h{2,}value:\h+"[^"\\]*(?:\\.[^"\\]*)*",\R},/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";