using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^{\R\h{2,}label:\h+""[^""\\]*(?:\\.[^""\\]*)*"",\R\h{2,}value:\h+""[^""\\]*(?:\\.[^""\\]*)*"",\R},";
string substitution = @"";
string input = @"{
label: ""Other"",
value: ""Other"",
},
{
label: ""this is \"" a test"",
value: ""1234"",
},";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}