# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^{\R\h{2,}label:\h+\"[^\"\\]*(?:\\.[^\"\\]*)*\",\R\h{2,}value:\h+\"[^\"\\]*(?:\\.[^\"\\]*)*\",\R},"
test_str = ("{\n"
" label: \"Other\",\n"
" value: \"Other\",\n"
"},\n\n"
"{\n"
" label: \"this is \\\" a test\",\n"
" value: \"1234\",\n"
"},")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.