const regex = /^{\R\h{2,}label:\h+"[^"\\]*(?:\\.[^"\\]*)*",\R\h{2,}value:\h+"[^"\\]*(?:\\.[^"\\]*)*",\R},/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^{\\R\\h{2,}label:\\h+"[^"\\\\]*(?:\\\\.[^"\\\\]*)*",\\R\\h{2,}value:\\h+"[^"\\\\]*(?:\\\\.[^"\\\\]*)*",\\R},', 'gm')
const str = `{
label: "Other",
value: "Other",
},
{
label: "this is \\" a test",
value: "1234",
},`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);