package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^{\R\h{2,}label:\h+"[^"\\]*(?:\\.[^"\\]*)*",\R\h{2,}value:\h+"[^"\\]*(?:\\.[^"\\]*)*",\R},`)
var str = `{
label: "Other",
value: "Other",
},
{
label: "this is \" a test",
value: "1234",
},`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}