using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\R+";
string substitution = @" ";
string input = @"put returns between paragraphs
for linebreak add 2 spaces at end
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}