re = /\R+/
str = 'put returns between paragraphs
for linebreak add 2 spaces at end
'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result