$re = '/\R+/';
$str = 'put returns between paragraphs
for linebreak add 2 spaces at end
';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;