const regex = /\R+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\R+', 'g')
const str = `put returns between paragraphs
for linebreak add 2 spaces at end
`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);