import Foundation
let pattern = #"\R+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
put returns between paragraphs
for linebreak add 2 spaces at end
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)