# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(O gato ).*?(subiu|caiu).*?( \d+m)/$1$2$3/g;t' <<< "O gato subiu no telhado de 10m, um homem jogou-lhe uma pedra e ele caiu de uma altura de 20m"