const regex = /(O gato ).*?(subiu|caiu).*?( \d+m)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(O gato ).*?(subiu|caiu).*?( \\d+m)', 'g')
const str = `O gato subiu no telhado de 10m, um homem jogou-lhe uma pedra e ele caiu de uma altura de 20m`;
const subst = `$1$2$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);