import re
regex = re.compile(r"(O gato ).*?(subiu|caiu).*?( \d+m)")
test_str = "O gato subiu no telhado de 10m, um homem jogou-lhe uma pedra e ele caiu de uma altura de 20m"
subst = "$1$2$3"
result = regex.sub(subst, test_str)
if result:
print(result)