re = /(O gato ).*?(subiu|caiu).*?( \d+m)/
str = 'O gato subiu no telhado de 10m, um homem jogou-lhe uma pedra e ele caiu de uma altura de 20m'
subst = '$1$2$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result