using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(O gato ).*?(subiu|caiu).*?( \d+m)";
string substitution = @"$1$2$3";
string input = @"O gato subiu no telhado de 10m, um homem jogou-lhe uma pedra e ele caiu de uma altura de 20m";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}