#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(O gato ).*?(subiu|caiu).*?( \d+m)"
Local $sString = "O gato subiu no telhado de 10m, um homem jogou-lhe uma pedra e ele caiu de uma altura de 20m"
Local $sSubst = "$1$2$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)