import Foundation
let pattern = #"(O gato ).*?(subiu|caiu).*?( \d+m)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"O gato subiu no telhado de 10m, um homem jogou-lhe uma pedra e ele caiu de uma altura de 20m"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2$3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)