use strict;
my $str = 'O gato subiu no telhado de 10m, um homem jogou-lhe uma pedra e ele caiu de uma altura de 20m';
my $regex = qr/(O gato ).*?(subiu|caiu).*?( \d+m)/p;
my $subst = '$1$2$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";