#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[0-9][a-z0-9_.]*)?[a-z][a-z0-9_.]*$"
Local $sString = "1.a12_12" & @CRLF & _
"111_121s" & @CRLF & _
"dfsdf" & @CRLF & _
"3412341" & @CRLF & _
"1dsfs3_c"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")