import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[0-9][a-z0-9_.]*)?[a-z][a-z0-9_.]*$";
final String string = "1.a12_12\n"
+ "111_121s\n"
+ "dfsdf\n"
+ "3412341\n"
+ "1dsfs3_c";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}