re = /^(?:[0-9][a-z0-9_.]*)?[a-z][a-z0-9_.]*$/m
str = '1.a12_12
111_121s
dfsdf
3412341
1dsfs3_c'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end