// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:[0-9][a-z0-9_.]*)?[a-z][a-z0-9_.]*$").unwrap();
let string = "1.a12_12
111_121s
dfsdf
3412341
1dsfs3_c";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}