$re = '/^(?:[0-9][a-z0-9_.]*)?[a-z][a-z0-9_.]*$/m';
$str = '1.a12_12
111_121s
dfsdf
3412341
1dsfs3_c';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);