import re
regex = re.compile(r"^(?:[0-9][a-z0-9_.]*)?[a-z][a-z0-9_.]*$", flags=re.MULTILINE)
test_str = ("1.a12_12\n"
"111_121s\n"
"dfsdf\n"
"3412341\n"
"1dsfs3_c")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")