#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(\+)|[^\d\n]+"
Local $sString = "(639)-234-2323" & @CRLF & _
"(042)-982-2234" & @CRLF & _
"0974829-928" & @CRLF & _
"+83246-983-34" & @CRLF & _
"+836(737)-898+78"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)