re = /^(\+)|[^\d\n]+/m
str = '(639)-234-2323
(042)-982-2234
0974829-928
+83246-983-34
+836(737)-898+78'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result