# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(\+)|[^\d\n]+"
test_str = ("(639)-234-2323\n"
"(042)-982-2234\n"
"0974829-928\n"
"+83246-983-34\n"
"+836(737)-898+78")
subst = "\\1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.