package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\+)|[^\d\n]+`)
var str = `(639)-234-2323
(042)-982-2234
0974829-928
+83246-983-34
+836(737)-898+78`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}