// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\+)|[^\d\n]+").unwrap();
let string = "(639)-234-2323
(042)-982-2234
0974829-928
+83246-983-34
+836(737)-898+78";
let substitution = "\\1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}