import Foundation
let pattern = #"^(\+)|[^\d\n]+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
(639)-234-2323
(042)-982-2234
0974829-928
+83246-983-34
+836(737)-898+78
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)