const regex = /^(\+)|[^\d\n]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\+)|[^\\d\\n]+', 'gm')
const str = `(639)-234-2323
(042)-982-2234
0974829-928
+83246-983-34
+836(737)-898+78`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);