use strict;
my $str = '(639)-234-2323
(042)-982-2234
0974829-928
+83246-983-34
+836(737)-898+78';
my $regex = qr/^(\+)|[^\d\n]+/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";