using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\+)|[^\d\n]+";
string substitution = @"\1";
string input = @"(639)-234-2323
(042)-982-2234
0974829-928
+83246-983-34
+836(737)-898+78";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}