# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?![\s\S]*<othermeta content="V7" name="version"\\/>)[\s\S]*<othermeta content="V6" name="version"\\/>\K/\n<othermeta content="V7" name="version"\/>/g;t' <<< "<othermeta content=\"V5.1\" name=\"version\"/>
<othermeta content=\"V5.2\" name=\"version\"/>
<othermeta content=\"V6\" name=\"version\"/>
"