$re = '/^(?![\s\S]*<othermeta content="V7" name="version"\/>)[\s\S]*<othermeta content="V6" name="version"\/>\K/';
$str = '<othermeta content="V5.1" name="version"/>
<othermeta content="V5.2" name="version"/>
<othermeta content="V6" name="version"/>
';
$subst = "\n<othermeta content=\"V7\" name=\"version\"/>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;