import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?![\\s\\S]*<othermeta content=\"V7\" name=\"version\"\\/>)[\\s\\S]*<othermeta content=\"V6\" name=\"version\"\\/>\\K";
final String string = "<othermeta content=\"V5.1\" name=\"version\"/>\n"
+ "<othermeta content=\"V5.2\" name=\"version\"/>\n"
+ "<othermeta content=\"V6\" name=\"version\"/>\n";
final String subst = "\\n<othermeta content=\"V7\" name=\"version\"/>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}