use strict;
my $str = '<othermeta content="V5.1" name="version"/>
<othermeta content="V5.2" name="version"/>
<othermeta content="V6" name="version"/>
';
my $regex = qr/^(?![\s\S]*<othermeta content="V7" name="version"\/>)[\s\S]*<othermeta content="V6" name="version"\/>\K/p;
my $subst = '\\n<othermeta content="V7" name="version"/>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";