import Foundation
let pattern = #"^(?![\s\S]*<othermeta content="V7" name="version"\/>)[\s\S]*<othermeta content="V6" name="version"\/>\K"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<othermeta content="V5.1" name="version"/>
<othermeta content="V5.2" name="version"/>
<othermeta content="V6" name="version"/>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n<othermeta content="V7" name="version"/>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)